Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 23:00 EDT
Scheduled
We will be conducting emergency maintenance on one of our phone servers in Atlanta, Ga tonight 9/11, at 11PM ET. We do not anticipate any prolonged service interruptions, however, if your phone is registered to that server then you may see it momentarily lose service while it is moved to a backup server. This failover should take less than a minute and will not affect calls already in progress. Once maintenance is completed the phones will go back to their original server.
If you have any questions or concerns, please reach out to our support team via https://support.trueipsolutions.com or by phone at (855) 878-8477.
Thank you,
True IP Solutions
Posted Sep 11, 2025 - 20:54 EDT
This scheduled maintenance affected: Geo Located Switches (Atlanta, GA (ATL1)).