Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2025 - 00:00 EST
Scheduled
On Sunday, November 23, from 12:00AM EST to 2:00AM EST we will be installing a small security update package to the voice servers. These updates include security patches for back-end access and do not affect anything in the user's portal or any functionality. There may be a brief service outage during this window but we do not anticipate it lasting more than a couple of minutes.
We apologize for providing such short notice. Security of our customers' data remains a top priority for us and any identified vulnerabilities will always be addressed as quickly as possible.
If you have any questions or concerns please don't hesitate to reach out to our support team by phone at (855) 878-8477 or by email at support@trueipsolutions.com.
Thank you,
True IP Solutions
Posted Nov 20, 2025 - 08:57 EST
This scheduled maintenance affected: Geo Located Switches (Atlanta, GA (ATL1), Atlanta, GA (ATL2), Charlotte, NC, Dallas, TX, MCNC 1, MCNC 2, MCNC 3, MCNC 4).