There was an upstream power issue that has been corrected. We will continue to monitor the situation to ensure continued operation but as of now the Charlotte, NC server is back online. If you're continuing to experience problems with your service please reach out to our support team for assistance.
Thank you,
True IP Solutions.
Posted Feb 10, 2026 - 10:16 EST
Investigating
We are aware of an issue affecting the data center in Charlotte, NC. We are investigating the cause and working to restore access to that server as quickly as possible. In the meantime, all services should have failed over to other geolocations and there should be no major impact to services. If you are experiencing issues with your phone service, please contact our support team at (855) 878-8477 or https://support.trueipsolutions.com for assistance.
We will keep you informed as we have more information. Thank you for your understanding and we look forward to resolving this quickly.
Thank you,
True IP Solutions
Posted Feb 10, 2026 - 09:53 EST
This incident affected: Geo Located Switches (Charlotte, NC).